星期五, 9月 08, 2006

FreeBSD 6更新Kernel

最近的安全性更新包括openssl,因此必須更新Kernel。
以前的版本在rc.conf設定kern_securelevel="2"及kern_securelevel_enable="YES"後,就無法更新kernel,但是現在居然可以了!

# cd /usr/src
# cvsup cvs-supfile
# make buildkernel installkernel; sync; sync; reboot
這樣就更新kernel了~

# cd /usr/src
# make buildworld
這樣是OK的,但是以下就不行
# make installworld

現在對FreeBSD的Security模式愈來愈不瞭解 OTZ

沒有留言: