星期四, 11月 29, 2007

KDE升級編譯問題

在FreeBSD升級KDE時遇到/usr/ports/x11/kdelibs3編譯時發生錯誤,爬文後才知道是/usr/ports/x11/kdelibs3並沒有先升級;所以要在/usr/ports/x11/kdelibs3先make deinstall install clean。(類似問題)

看來這問題已經出現蠻久了,主要是因為維護者設定kdelib在某幾個版本內算相容,事實則不然。希望維護者把Makefile裏LIB_DEPENDS的kdelibs版本寫成和kdebase3一樣,否則仍然會常出現呀 Orz (在下寄了封mail,希望有人處理。但是照以往的經驗,應該沒人回信

Update:有位老兄回了,但我的英文太爛,他似乎沒搞懂我的意思,因此再寫一封給他。

Update:這位老兄說,應該不會發生這種事,因此可能是因為我先灌PCBSD再portupgrade。看來我不適合用PCBSD呀~

沒有留言: