星期二, 5月 01, 2012

Ubuntu 12.04的ruby

不知為何,Ubuntu 12.04只有ruby 1.8和ruby 1.9.1,這樣很難相信它是一個最新的套件。
結果後來才發現它有ruby-rvm的套件,所以我就
sudo apt-get install ruby-rvm
但這樣還不夠,它不會自動加到PATH,只好手動加
export PATH="$PATH:/usr/share/ruby-rvm/bin"
到 /etc/bash.bashrc 。

快要完成了,還少一個套件, sudo apt-get install libyaml-dev,接下來就是 rvm install 1.9.3 && rvm 1.9.3 --default
最後用 rvm list 確認是否有裝好,鐵道迷接著可以 sudo gem install rails 了。
如果裝完仍然顯示找不到rails或bundle,別忘了要 rvm reload 。

Update:看了原廠的下載網頁才知道:
原來會裝1.9.2呀...這樣就可以放膽用。

不過由於Debian/Ubuntu很雞婆熱心維護套件之間的相容性,所以預設不能自行升級gem和rails,所以我就不裝系統的rails (得自己裝ruby1.9.1-dev、zip、unzip等等套件,如果有缺請自己補),自行 export REALLY_GEM_UPDATE_SYSTEM=whatever && sudo gem install rails

沒有留言: