星期一, 12月 05, 2011

jQuery UI 配合的 jQuery 版本有限制

認識我的朋友都知道,我不但是重灌狂人級,也是升級狂人,手邊的OS或軟體一定要升級到最新版才爽。

前年底做了個小系統,使用FullCalendar,一開始是jQuery 1.3.2,然後我就一直升級jQuery,也都沒什麼問題,直到這個月從jQuery 1.6.4升到jQuery 1.7.1時,問題出現了。

我一直以為jQuery UIjQuery是同一家出品,只要最新版本應該都相容,jQuery UI也只有寫jQuery 1.3.2+,沒想到jQuery UI的 drag and drop 出現問題,它只能用在jQuery 1.3.2~jQuery 1.6.4。

根據在下去看jQuery UI的source code,是因為它大量使用isNaN,jQuery 1.7把isNaN廢掉了。

結論:升級前請停、看、聽。

沒有留言: