跳到主要內容

Server 2003移除PowerShell 1.0升級Server 2008

因為Server 2003停止支援,加上沒有新版的Smb,在Windows 10 build 1709之後,預設移除SMBv1支援,所以要升級舊版的Server 2003。當您有安裝的 Windows PowerShell 1.0 時,您無法升級以 Windows 為基礎的作業系統,但我根本找不到KB926139 。
這下子真的很大條,後來想要試看看移除程式和機碼有沒有效。
把 Registry裡的 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1.0 刪除
以及 %SystemRoot%\System32\PowerShell 裡的檔案,通常是 C:\Windows\System32\PowerShell,我這台是NT4.0升級上來的,所以是 C:\Winnt\System32\PowerShell。

再執行Server 2008安裝程式,就可以升級。
若遇到VMware Tools無法升級或無法安裝時,可能是舊版的VMware tools 干擾,用我在這裡提過的方法,使用 setup.exe /c或setup64.exe /c 移除舊版就可以正常安裝,收工!

留言

這個網誌中的熱門文章

自然人憑證讀卡機驅動程式

鳥毅用的是第一代的自然人憑證讀卡機,EZ100PU(後來有同事買EZmini可以讀SIM卡似乎更好),每年報稅時用一次。

本來只是要申請些政府業務,一時之間找不到光碟,沒想到在驅動程式下載居然看到Linux和Mac的驅動程式,剩下的就是政府單位的網頁和程式應該改版了吧!!!

在Windows Server設定L2TP over IPSec VPN

簡單地說,macOS Sierra與iOS 10發表後,大家忽然發現Apple不再支援PPTP,所以一定得設定其他的VPN型態。若不要另外裝client,用L2TP是最方便的,SSL VPN雖然好,但若沒有安裝Agent要連線到任一電腦或是非網頁服務還是挺麻煩的。